Fork me on GitHub

Installation

Requirements

  • Ruby >= 1.9

In addition to the standard Ruby interpreter (MRI), Whois has been successfully tested against several Ruby implementations.

Compatibility

  • Whois >= 3.0 requires Ruby 1.9.2 or newer.
  • Whois >= 1.5 requires Ruby 1.8.7 or newer.
  • For older versions of Ruby, see the CHANGELOG.md file.

Install

Stable

The best way to install Whois is via RubyGems.

$ gem install whois

You might need administrator privileges on your system to install the Gem.

Development

The Whois repository is hosted on GitHub. You can start by watching or cloning the repository.

$ git clone git://github.com/weppos/whois
$ cd whois

Use Bundler to install the development dependencies.

$ bundle

Now run the tests to make sure everything is working as expected.

$ rake test